NAV Navbar

Official System Requirements

These are the officially supported and fully tested operating systems, browsers, Python runtimes, package managers, and MATLAB versions for installation and use of the Bonsai Platform. Please contact support if you are an active customer and have questions about a configuration that is supported here.

Operating Systems

  • Windows 10
  • Windows 7
  • Ubuntu 16.04

Browsers

  • Latest version Chrome
  • IE 11

Python Runtimes

  • Python 3
    • 3.5/3.6 32-bit/64-bit for Windows
    • 3.5/3.6 64-bit for Ubuntu 16.04
  • Anaconda 5+
    • 3.6 32-bit/64-bit for Windows
    • 3.6 64-bit for Ubuntu 16.04

Package Managers

  • bonsai-ai
    • Pip from pypi (Anaconda users must use conda to install pip)
  • libbonsai
    • MSI for Windows
    • apt-get deb for Ubuntu 16.04
  • Version 2018a